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Introduction to NavMesh                                                

Navigation System in Unity 

The Navigation System allows you to create characters which can navigate the game world. It gives your characters 

the ability to understand that they need to take stairs to reach second floor, or to jump to get over a ditch. 

The Unity NavMesh system consists of the following pieces: 

• NavMesh (short for Navigation Mesh) is a data structure which describes the walkable surfaces of the game 

world and allows to find path from one walkable location to another in the game world. The data structure is 

built, or baked, automatically from your level geometry. 

• NavMesh Agent component help you to create characters which avoid each other while moving towards 

their goal. Agents reason about the game world using the NavMesh and they know how to avoid each other 

as well as moving obstacles. 

• Off-Mesh Link component allows you to incorporate navigation shortcuts which cannot be represented 

using a walkable surface. For example, jumping over a ditch or a fence, or opening a door before walking 

through it, can be all described as Off-mesh links. 

• NavMesh Obstacle component allows you to describe moving obstacles the agents should avoid while 

navigating the world. A barrel or a crate controlled by the physics system is a good example of an obstacle. 

While the obstacle is moving the agents do their best to avoid it, but once the obstacle becomes stationary it 

will carve a hole in the navmesh so that the agents can change their paths to steer around it, or if the 

stationary obstacle is blocking the path way, the agents can find a different route. 

 

Figure 1 NavMesh Overview 

Building a NavMesh 
The process of creating a NavMesh from the level geometry is called NavMesh Baking. The process collects the 

Render Meshes and Terrains of all Game Objects which are marked as Navigation Static, and then processes them 

to create a navigation mesh that approximates the walkable surfaces of the level. 

In Unity, NavMesh generation is handled from the Navigation window (menu: Window > Navigation). 
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Let’s start by Creating a NavMesh: 

• Create a new Unity project and add a Plane Game Object to it.  

• Reset the Plane Transform component. Then scale it in 𝑋 and 𝑍 to 5. 

• Open the Navigation Window (Window > Navigation). 

 

Figure 2 Navigation Window 

• Choose the Plane in the Inspector then move to the Navigation Window Object Tab. Check the Navigation 

Static option.  

 

Figure 3 Marking the selected GameObject as Navigation Static. 

• Move to the Bake tab and click the Bake button. 

After doing the steps above you should see a blue overlay on your Plane game object as in Figure 4. This is the 

NavMesh. You should also see a folder created with the same name of the Scene that contain a file called NavMesh. 

 

Figure 4 
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The Navigation window contains four tabs: 

• Agents 

Allows us to define different types of Agents that will be able to walk across the NavMesh.  

• Areas  

This is where we can define specific tags that are used for parts of the world. We can assign costs to them as 

well. This allows us to create areas in the map with penalties assign to them. E.g. we can assign cost to sand 

area by which we can make our character move slowly when it walks on sand.  

• Bake 

This is where we Bake the navigation mesh of the environment and set the default baking settings. 

• Object  

This allows us to filter the scene in the hierarchy view such that we can identify parts that are considered as 

part of the NavMesh. More importantly, we can set an object as being Navigation Static which is needed for 

it to be used in the navigation system. 

Creating a NavMesh Agent 
NavMeshAgent components help you to create characters which avoid each other while moving towards their goal. 

Agents reason about the game world using the NavMesh and they know how to avoid each other as well as other 

moving obstacles. Pathfinding and spatial reasoning are handled using the scripting API of the NavMesh Agent. 

• Add a Capsule GameObject to the scene this will represent our character. 

• Change the Capsule transform position Y property to 1.  

• Add a NavMesh Agent   component to the Capsule GameObject. You can do that by clicking on Add 

Component button then choose Navigation and NavMesh Agent. 

• If you uncheck the Capsule Collider and Mesh Renderer you will see a green wired Cylinder this is our Agent. 

 

Figure 5 The NavMesh Agent appears after unchecking the Capsule Collider and the Mesh Renderer component. 

Now let’s try to move our Agent to a predefined destination.  

• Add a Cube GameObject. 

• Create a new Script (rename it to “AgentMove”), this script will use the NavMesh Agent component to 

move to a predefined destination. 

https://docs.unity3d.com/Manual/StaticObjects.html
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    public Transform destination; 

    private NavMeshAgent agent; 

    // Use this for initialization 

    void Start () { 

        agent = GetComponent<NavMeshAgent>(); 

        if(destination != null){ 

            agent.SetDestination(destination.position); 

        } 

    }  

Code Snippet 1 

• Add the Script to the Capsule GameObject. 

• Drag the Cube to the destination field in the Script component. 

After writing the above code, when you run the game, the Agent should go to the Cube and then stops. 

Obstacles and NavMesh Obstacle 
Let’s try to add obstacles and see what happen when we place them in Agent path. 

• Add a new Cube Game Object, rename it to “wall”, then scale it in X, Y, and Z to make it as a wall. 

• Change the Wall position to place it in the path between our Agent and the Target. 

 

Figure 6 The blue Capsule represent our Agent; the green Cube is the destination and the Gray Cube is the Obstacle 

If you run the game now you will notice that the Agent walk through the obstacle. And if you open the 

Navigation Window while the Scene View is opened you will notice that the walkable area includes the place 

where the obstacle lies on. 

• Select the Wall then open the Navigation Window after that select the Object tab. 

In the Object tab, check Navigation Static. Then re-bake the NavMesh. 

You will notice that the NavMesh surface changed to a set of linked Polygons. And the top (ceil) of the Wall is 

marked as walkable area. 
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Figure 7 

•  If you don’t want the Top of the Wall GameObject to be walkable, change the Navigation Area in the Object 

Tab of the Navigation window to Not Walkable and Re-bake the NavMesh. 

 

Figure 8 

When you play the game now you will notice that a set of polygons is shaded, these polygons are the Path that our 

Agent will traverse to go to its destination. 

You will also notice that that the not-walkable area around the wall are too small to the extent that the Agent is 

touching the wall while walking. 

 

Figure 9 
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The handling of this problem will guide us toward the NavMesh Obstacle component. NavMesh Obstacle 

components can be used to describe obstacles the agents should avoid while navigating. For example, the agents 

should avoid physics-controlled objects, such as crates and barrels while moving. 

• Select the Wall GameObject, then move to the Inspector. 

• Add a Nav Mesh Obstacle Component. 

 

Figure 10 

• Change the Size of the NavMesh Obstacle in X and Z to 1.25.  

 

Figure 11 

Moving an Agent to a Position Clicked by the 

Mouse 

Rays from the Camera 
Any point in the camera’s view corresponds to a line in world space. It is sometimes useful to have a mathematical 

representation of that line and Unity can provide this in the form of a Ray object. The Ray always corresponds to a 

point in the view, so the Camera class provides the ScreenPointToRay and ViewportPointToRay 

functions. Each of these functions returns a Ray which consists of a point of origin and a vector which shows the 

direction of the line from that origin. The Ray originates from the near clipping plane rather than the Camera’s 

transform.position point. 

ScreenPointToRay ViewportPointToRay 

ScreenPointToRay expects the point to be 
provided as a pixel coordinate. 

ViewportPointToRay takes normalized 
coordinates in the range 0..1 (where 0 represents the 
bottom or left and 1 represents the top or right of the 
view). 

 

https://docs.unity3d.com/ScriptReference/Ray.html
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Raycasting 
The most common use of a Ray from the camera is to perform a raycast out into the scene. A raycast sends 

an imaginary “laser beam” along the ray from its origin until it hits a collider in the scene. Information is then 

returned about the object and the point that was hit in a RaycastHit object. This is a very useful way to locate an 

object based on its onscreen image. 

Moving Agent with Mouse Click 
Now let’s start working. We will modify our previous script.  

• Remove the destination transform and the If condition in the Start method. 

• We want to make a Ray (A ray is an infinite line starting at origin and going in some direction) from 

the Camera to the mouse click position.  

o Make a check for left Mouse Button clicking in the Update method. 

if (Input.GetKeyDown(KeyCode.Mouse0)) 

{ 

 //do something 

}  

Code Snippet 2 

o We want to get a Ray from the Camera to the mouse click point. We will use 

Camera.ScreenPointToRay to achieve that. It returns a ray going from camera through a 

screen point. 

 

o Make a Raycast using the Ray returned from the previous step. To do that we will use 

Physics.Raycast function. This Raycast should collide with our Plane (Ground). We will use a 

RaycastHit to get information about the collision point. 

Camera.ScreenPointToRay 
public Ray ScreenPointToRay(Vector3 position); 

Returns a ray going from camera through a screen point. 

Resulting ray is in world space, starting on the near plane of the camera and going through 

position's (x,y) pixel coordinates on the screen (position.z is ignored). 

Screenspace is defined in pixels. The bottom-left of the screen is (0,0); the right-top is 

(pixelWidth,pixelHeight). 

Source:  Camera.ScreenPointToRay  from Unity Scripting Reference 

https://docs.unity3d.com/ScriptReference/Physics.Raycast.html
https://docs.unity3d.com/ScriptReference/Ray.html
https://docs.unity3d.com/ScriptReference/Vector3.html
https://docs.unity3d.com/ScriptReference/Camera.ScreenPointToRay.html
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o Using the RaycastHit we will set our Agent destination to the Hit point. 

RaycastHit.point: The impact point in world space where the ray hit the collider. 

        if (Input.GetKeyDown(KeyCode.Mouse0)) 

        { 

            RaycastHit hit;                      

            Ray ray = Camera.main.ScreenPointToRay(Input.mousePosition); 

            if (Physics.Raycast(ray, out hit)) 

            {                                       

                agent.destination = hit.point; 

            } 

        }  

Figure 12 

 

 

 

Physics.Raycast 
public static bool Raycast(Ray ray, out RaycastHit hitInfo, float maxDistance = Mathf.Infinity, 

int layerMask = DefaultRaycastLayers,QueryTriggerInteraction queryTriggerInteraction = 

QueryTriggerInteraction.UseGlobal); 

Casts a ray, from point ray.origin, in direction ray.direction, of length maxDistance, 

against all colliders in the scene. 

Returns bool True when the ray intersects any collider, otherwise false. 

Source:  Physics.Raycast from Unity Scripting Reference 

https://docs.unity3d.com/ScriptReference/Ray.html
https://docs.unity3d.com/ScriptReference/RaycastHit.html
https://docs.unity3d.com/ScriptReference/QueryTriggerInteraction.html
https://docs.unity3d.com/ScriptReference/Physics.Raycast.html

