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Endless Runner (Cont.) 
 

In the previous two tutorials we start making the Endless Runner Game, and we were able to make the following: 

• Add a character to the Scene and add a Running animation to it. 

• Move the Character using Character Controller Move function. 

• Create a simple Camera animation using a custom script. 

• Generate random platforms in runtime. 

In this section we are going to: 

• Adding Score and Difficulty to our game. 

• Handle Death condition. 

• Add Menus using Unity UI, we will use Images and Text to create menus and use Buttons. 

• Making simple Death Menu, a menu that appears when the player dies. 

Game UI, Score and Difficulty 

In this section we will introduce Unity UI, use it to display Score. We will also as difficulty levels to our game 

• Create a new Image GameObject. 

o Right click on the Hierarchy > UI > Image 

 

 

(a) (b) 
Figure 1 (a) Creating a new Image UI element. (b) the GameObject add that correspond to the Image UI element 

https://docs.unity3d.com/Manual/class-CharacterController.html
https://docs.unity3d.com/ScriptReference/CharacterController.Move.html
https://docs.unity3d.com/Manual/UISystem.html
https://docs.unity3d.com/Manual/script-Image.html
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o You will notice that a Canvas had been added to the Hierarchy and it is the Parent of our Image. 

 

o Select the Image GameObject from the Hierarchy. And then focus on the Inspector. You will notice 

that there is a Rect Transform component. 

 

Figure 2 

 

Canvas 
The Canvas is the area that all UI elements should be inside. The Canvas is a Game Object with a 

Canvas component on it, and all UI elements must be children of such a Canvas. 

Creating a new UI element, such as an Image using the menu GameObject > UI > Image, 

automatically creates a Canvas, if there isn’t already a Canvas in the scene. The UI element is 

created as a child to this Canvas. 

The Canvas area is shown as a rectangle in the Scene View. This makes it easy to position UI 

elements without needing to have the Game View visible at all times. 

Canvas uses the EventSystem object to help the Messaging System. 

Source: Canvas from Unity Manual. 

https://docs.unity3d.com/Manual/UICanvas.html
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Rect Transform 
The Rect Transform is a new transform component that is used for all UI elements instead of the 

regular Transform component. 

Rect Transforms have position, rotation, and scale just like regular Transforms, but it also has a 

width and height, used to specify the dimensions of the rectangle. 

Pivot 
Rotations, size, and scale modifications occur around the pivot so the position of the pivot affects 

the outcome of a rotation, resizing, or scaling. When the toolbar Pivot button is set to Pivot mode, 

the pivot of a Rect Transform can be moved in the Scene View. 

Anchors 
Rect Transforms include a layout concept called anchors. Anchors are shown as four small 

triangular handles in the Scene View and anchor information is also shown in the Inspector. 

If the parent of a Rect Transform is also a Rect Transform, the child Rect Transform can be 

anchored to the parent Rect Transform in various ways. For example, the child can be anchored to 

the center of the parent, or to one of the corners. 

Anchor presets 
In the Inspector, the Anchor Preset button can be found in the upper left corner of the Rect 

Transform component. Clicking the button brings up the Anchor Presets dropdown. From here you 

can quickly select from some of the most common anchoring options. You can anchor the UI 

element to the sides or middle of the parent, or stretch together with the parent size. The 

horizontal and vertical anchoring is independent. 

 

Source: Basic Layout from Unity Manual. 

https://docs.unity3d.com/Manual/UIBasicLayout.html
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o Using the Anchor Preset, change the Anchor Point  to the Top Middle .   

  
(a) (b) 

Figure 3 (a) Default Anchor Point position (middle, center). (b) Anchor Point in the (top, middle) 

o Set the Pivot to the same location as the Anchor Point, by holding Shift key and press in the Middle-

Top button on the Anchor Preset. 

o Move the Image to the place of the Pivot point and Anchor point by holding Alt and then press on 

the Middle-Top button on the Anchor Preset. 

o Go to the Image component and change the Source Image to “Background”.  

 

Figure 4 Image component of the Image UI GameObject. 

o If you try to resize the Game View you will notice that the Image is not scaling with the Canvas. We 

want it to scale with it. 

Select the Canvas in the Hierarchy, then go to the Canvas Scaler ( Script ) component then change UI 

Scale Mode to Scale with Screen Size.  

o Change the Image GameObject name to “ScoreContainer”.  

From now on I will refer to this Image GameObject as ScoreContainer. 

• Adding Text on top of our Image. 

Now we want to add a text that will appear on top of our ScoreContainer, and will represent our Score. 

The Text that we will create must be a child of the ScoreContainer. 

o Right click on ScoreContainer in the Hierarchy, Choose UI > Text.  

https://docs.unity3d.com/Manual/script-CanvasScaler.html
https://docs.unity3d.com/Manual/script-Text.html
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Figure 5 

o Rename the Text GameObject to “Score”. 

o Select the Text GameObject, Score, form the Hierarchy and then go to the Inspector then scroll 

down to the Text (Script) component. The Text component, which is also known as a Label, has a 

Text area for entering the text that will be displayed. It is possible to set the font, font style, font size 

and whether the text has rich text capability1. 

o We want the Text to have the same size as our ScoreContainer. To do that: 

▪ Stretch Text to both axis by selecting the corresponding icon  in the Anchor Presets.  

▪ Reset the Rect Transform Position fields (left, right, top, bottom and Pos z) to 0. 

Now the Text have the same size of the ScoreContainer. 

• “Score”, our Text GameObject, has a Text Component, and that is what we need to modify. We need to get 

the Text component inside the “Score” and modify the text inside it. 

To modify the Score text we need to store the following information: 

▪ The Score value, we will store It as a private float field. 

▪ A reference to the Score Text GameObject. 

We want also to add some Difficulty level, this will increase by time and when it increases the Player speed 

increases too. We will need the following information to achieve that:   

▪ The current Difficulty Level which will be a private int. 

▪ The Maximum Difficulty Level. 

▪ The required score to next Difficulty Level. 

o Create a new Script in the Player, call it “Score”. 

o Declare the following fields: 

                                                           
1 UI Visual Components from Unity Documentation. 

https://docs.unity3d.com/Manual/UIVisualComponents.html
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    public Text scoreText; 

    private float score = 0.0f; 

    private int difficultyLevel = 1; 

    private int maxDifficultyLevel = 10; 

    private int scoreToNextLevel = 10;  

Code Snippet 1 

o  To be able to use the Text class, you should import it by adding the following line: 

using UnityEngine.UI;  
o In every second we want to increase the Score by some value. If the score reaches the 

scoreToNextLevel we should increase the difficultyLevel and we will also increase 

scoreToNextLevel to prevent leveling up in the next second. 

Add the following code to the Update method of the Score script:  

        if(score >= scoreToNextLevel){ 

            LevelUp(); 

        } 

        score += Time.deltaTime; 

        scoreText.text = ((int)score).ToString();  

Code Snippet 2 

o Don’t forget to drag the Score Text GameObject to the Score script in the Editor. 

o We now going to implement LevelUp function. It will update the scoreToNextLevel, 

difficultyLevel and Player speed, the speed value in the 

PlayerMovmentController. 

The implementation of LevelUp function is given below. 

    private void LevelUp() 

    { 

        if(difficultyLevel == maxDifficultyLevel){ 

            return; 

        } 

        scoreToNextLevel *= 2; 

        difficultyLevel++; 

        //changing the speed of the player 

    }  

Code Snippet 3 

o To change the speed of the Player, that is in the PlayerMovementController, we will 

declare a public method inside it, this method will take one parameter that will be added to 

speed. Add the following function to the PlayerMovementController. 

    public void SetSpeed(float modifier){ 

        speed = 5.0f + modifier; 

    }  

Code Snippet 4 

o Finally, we need to call SetSpeed inside the LevelUp function. 

You should remember that both Score and PlayerMovementController are components 
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inside the Player GameObject. So, we will just get the PlayerMovementController 

component of the player inside the Score script using GetComponent function. 

    private void LevelUp() 

    { 

        if(difficultyLevel == maxDifficultyLevel){ 

            return; 

        } 

        scoreToNextLevel *= 2; 

        difficultyLevel++; 

        //changing the speed of the player 

        GetComponent<PlayerMovementController>().SetSpeed(difficultyLevel); 

    }  

Code Snippet 5 

o I also want the Score to go up faster when the difficultyLevel increase. That can be easily achieved by 

changing the score increment line to  

 score += Time.deltaTime * difficultyLevel; 

Handling Death and Death Menue 

In this section we are going to handle Player Death, that is we want to change what happen when our character 

collides with one of the obstacles. What we want to do when that happen, is as follow: 

• Stop the player movement 

• Stop score increment 

• Open a Menu, which we will call DeathMenue, that contains Player score and two Buttons one to Restart the 

Game and one to go to a Main Menu that we will create later. 

Let’s start by handling Collision. We want to detect when the player collides with an obstacle in front of him, that is 

we don’t care about collision with the Ground or the Walls and Fences. 

Remember that our Player has a Character Controller component which contain a Capsule Collider. Character 

Controller provide a callback (Message) called OnControllerColliderHit. OnControllerColliderHit 

is called when the controller hits a collider while performing a Move2. This function gets a 

ControllerColliderHit argument which is used by 

CharacterController.OnControllerColliderHit to give detailed information about the collision and 

how to deal with it. 

• Add the OnControllerColliderHit function to the PlayerMovementController script. 

• The first thing we want to do is to ignore the collision with the Ground. Remember that our ground is 

composed of two main GameObjects Fence and Ground. 

 

Figure 6 

o Add a new Tag, call it “Ground”, and assign it to the Ground GameObject in all the Prefabs we are 

using as our Ground. To add a new Tag, do the following: 

                                                           
2 CharacterController from Unity Scripting Reference. 

https://docs.unity3d.com/Manual/script-Button.html
https://docs.unity3d.com/ScriptReference/ControllerColliderHit.html
https://docs.unity3d.com/ScriptReference/CharacterController.html
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▪ Expand the Prefabs we made before and select the Ground GameObject inside all of them. 

 

Figure 7 

▪ Expand the Tag dropdown > choose Add Tag. 

 

Figure 8 

▪ The Inspector will change to Tags and Layers, expand the Tag menu and click the plus sign to 

add the new Tag. 

 

Figure 9 

o We will use two important properties of the hit object. The first one is gameObject which is the 

game object that was hit by the controller. We will use it to get the Tag of the object that we collide 
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with. The second one is point which is the impact point in world space and it is a Vector3 object. 

It will be used to check if what we hit is in front of us. 

    private void OnControllerColliderHit(ControllerColliderHit hit) 

    { 

        if (hit.gameObject.tag == "Ground") 

        { 

            return; 

        } 

    }  

Code Snippet 6 

• We want to make sure that the player will die if and only if he/she hit an obstacle that is in front of him. To 

do that we will use the point.z field in the hit object. When the character die, we will call a function, 

Death, that will handle the death. We will work now on the CharacterMovementController script. 

o Declare a private bool, call it isDead, and initialize it to false. 

o Set isDead to true in the Death function. 

o Call Death function in OnControllerColliderHit if the object that we hit was in front of us 

and wasn’t the ground. 

o To disable the movement of the player, add check on isDead at the beginning of the Update 

method. 

    private void OnControllerColliderHit(ControllerColliderHit hit) 

    { 

        if (hit.gameObject.tag == "Ground") 

        { 

            return; 

        } 

        //check if we hit an object that is in fornt of us 

        if (hit.point.z > transform.position.z + controller.radius) 

        { 

            Death(); 

        } 

    } 

    private void Death() 

    { 

        Debug.Log("Deth"); 

        isDead = true; 

    }  

Code Snippet 7 

o Add the following condition at the very beginning of the Update method. 

if(isDead){ 

            return; 

        }  

Code Snippet 8 

• We want to turn off score when the player collides with an obstacle.  

o Create a new private bool inside Score script, call it isDead and initialize it to false. 
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o Create new public function inside the Score script, call it OnDeath. This function will set 

isDead to true. We will call this function from the CharacterMovementController in the 

Death function. 

    public void OnDeath(){ 

        isDead = true; 

    }  

Code Snippet 9 OnDeath function inside Score script. 

    private void Death() 

    { 

        Debug.Log("Deth"); 

        isDead = true; 

        GetComponent<Score>().OnDeath(); 

    }  

Code Snippet 10 Call OnDeath function from the Score Script inside the CharacterMovementController Death function 

o Finally make an if condition that return from the beginning of the Update method inside the 

Score script when isDead is true. 

if(isDead){ 

            return; 

}  

Code Snippet 11 

• Now we want to make a simple Death Menu. 

o Add a new Image UI GameObject as a child of the Canvas. 

▪ Rename the Image to “DeathMenu”. 

▪ Make the “DeathMenu” stretched both horizontal and vertical. 

▪ Reset its Rect Transform (left, right, top, bottom and Z pos). 

▪ Change its color to black. 

 

Figure 10 
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o On top of the DeathMenu we will display the Score and add two buttons for the “Play” and the 

“Back to Menu”. 

▪ Duplicate the ScoreContainer and make the copy as a child of the DeathMenu. Then 

Rename it to “EndScore”. 

▪ Put the EndScore in the Center and Increase its width and height. 

 

Figure 11 

▪ Add a Button inside (as a child of) DeathMenu and change its position to be a little below 

the EndScore. Also change the name of the Button to “PlayButton” and change the Text 

inside that button to “Play”. 

▪ Duplicate the Button, change its name to “MenuButton” and change the Text inside it to 

“Menue”. Also move it a little below the PlayButton. 

 

Figure 12 

o When we play the game, we will only see the DeathMenu. What we want to do is to only activate it 

when the player dies.  
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▪ Add a new Script in the DeathMenu call it “DeathMenu”.  

▪ After opening it, the first thing we want to do is to deactivate the DeathMenu when the 

game start. To do that change the Start function as follow: 

    void Start () { 

        gameObject.SetActive(false); 

    }  

Code Snippet 12 

 

o We will need to make a function that is called form outside the DeathMenu script, that will tell us 

when our character dies. 

▪ Declare a public function that takes a float “score” as a parameter. Call it 

ToggleEndMenu. 

▪ We will call this function form the Score script and we will send the score from there to 

modify the DeathMenu score text. 

▪ Declare a public field of type DeatMenu inside the Score script. Call it “deathMenu”. 

Then drag it from the Inspector to the Score script inside the Player GameObject. 

▪ In the OnDeath function in the Score script call ToggleEndMenu and send score to it. 

    public void OnDeath(){ 

        isDead = true; 

        deathMenu.ToggleEndMenu(score); 

    }  

Code Snippet 13 

▪ In the ToggleEndMenu, we should reactivate our DeatgMenu GameObject. And display the 

score inside the Text that is in it. 

• In the DeathMenu script add a public Text field call it “scoreText”. 

MonoBehaviour 
MonoBehaviour is the base class from which every Unity script derives. 

Inherited Members 
Properties 

gameObject The game object this component is attached to.  

A component is always attached to a game object. 

transform The Transform attached to this GameObject. 

tag The tag of this game object. 

 

Source: MonoBehaviour from Unity Script Reference. 

https://docs.unity3d.com/ScriptReference/Component-gameObject.html
https://docs.unity3d.com/ScriptReference/Component-transform.html
https://docs.unity3d.com/ScriptReference/Component-tag.html
https://docs.unity3d.com/ScriptReference/MonoBehaviour.html
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• Set its text property inside the ToggleEndMenu function to the score the 

function takes as an argument. Your function should look like the Code Snippet 

below. 

    public void ToggleEndMenu(float score){ 

        gameObject.SetActive(true); 

        scoreText.text = ((int)score).ToString();        

    }  

Code Snippet 14 

• Remember to Drag the Score Text, that reside in EndScore GameObject to the 

DeathMenu Script scoreText field. 

o Now when you play the Game if you collide with an obstacle the menu should be displayed with 

your score. 

 

Figure 13 

• Let’s make our Buttons work. 

o Inside the DeatMenu script add the following two public functions. 

    public void Restart(){ 

 

    } 

    public void ToMenu(){ 

         

    }  

Code Snippet 15 

o We will use Unity Scene Management Scene Manager to Reload the Game Scene in the Restart 

method and to open another Scene in the ToMenu method. 

o Add the following line to import the Scene Management 

using UnityEngine.SceneManagement 
 

https://docs.unity3d.com/ScriptReference/SceneManagement.SceneManager.html
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o Restart function should load the current or active scene. To do that we will use LoadScene. 

    public void Restart(){ 

        SceneManager.LoadScene(SceneManager.GetActiveScene().name); 

    }  

Code Snippet 16 

o ToMenu function will Load the “Menu” Scene which we will create later. 

    public void ToMenu(){ 

        SceneManager.LoadScene("Menu"); 

    }  

Code Snippet 17 

o Now we want to make the two buttons work. 

▪ Select the PlayButton in the Hierarchy then move to the Inspector and find the Button 

Component. 

 

Figure 14 

SceneManager 
class in UnityEngine.SceneManagement 

Scene management at run-time. 

Static Methods 
GetActiveScene Gets the currently active Scene. 

LoadScene Loads the Scene by its name or index in Build Settings. 

Source: SceneManager from Unity Script Reference. 

https://docs.unity3d.com/ScriptReference/SceneManagement.SceneManager.GetActiveScene.html
https://docs.unity3d.com/ScriptReference/SceneManagement.SceneManager.LoadScene.html
https://docs.unity3d.com/ScriptReference/SceneManagement.SceneManager.html
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▪ You will notice that there is a list (On Click) at the end of that Component. Click on the Plus 

sign to add a new On Click event. 

 

Figure 15 

▪ Drag the DeatMenu GameObject to the place inside the On Click list. After doing that you 

will notice that the list of function is active. Open it, then choose DeathMenu script and 

finally choose the Restart function.  

 

Figure 16 

▪ Do the same thing to the MenuButton but change the function to ToMenu. 

After doing that the Play button should restart the Game. 

o Now let’s create the Menu Scene. 

▪ Create a new Scene call it “Menu”. 

▪ You are free to Design your scene, but I made a simple one. 

• Disable the Sky Box by going to Window > Lighting > Settings then go to the 

Environment and change Sky Box material to None. 

• I used the Wood Column prefab from the Mega Fantasy Props Pack.  

• Add one of our platform (Ground, tile) prefabs. 

• Create a Text and change its text to “Endless Runner Game”. Then change its color 

to White. 

• Add a Button and change the text inside it to “Play”. 

▪ To make the Play button works create a new Script call it MainMenu. Add a public function 

to it call it Play and use it to load the Scene that contains our Game.  

▪ Create an empty GameObject call it “MainMenu”. Assign MainMenu script to it. Then add a 

new On Click item in the Button and refer to the ManMenu GameObject in it.   

https://assetstore.unity.com/packages/3d/environments/fantasy/mega-fantasy-props-pack-87811
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▪ Finally add reference to Play function in the Button On Click list. 

 

Figure 17 

• To be able to move from scene to scene we should add our Scenes in the build settings. 

o Open File > Build Settings 

o Then Drag our Game Scene and Menu Scene to the Scenes in Build. 

Try to play the Game you will find that there is Darker Lighting than what happen when we Play from Our Game 

Scene Directly. To fix this do the following: 

• Open Window > Lighting > Settings 

• Uncheck Auto Generate and Click the Generate Lighting button. 

• Do that for both scenes our Game Scene and the Menu Scene. 

  

  


